Some calls failing to connect

Incident Report for Ringba

Resolved

Underlying problem was confirmed fixed by the provider at 10:05 UTC. Ongoing monitoring has confirmed and the incident is permanently resolved.
Posted Jul 22, 2025 - 07:15 PDT

Update

Issue is resolved but we will continue to monitor.
Posted Jul 21, 2025 - 14:56 PDT

Monitoring

We observed a significant drop in inbound call volume earlier. The issue appears to have stabilized, but we're continuing to monitor and are working with carriers to determine the root cause.
Posted Jul 21, 2025 - 12:19 PDT

Update

Continuing to investigate. Call volumes and connections are approaching normal levels again.
Posted Jul 21, 2025 - 11:51 PDT

Investigating

Ringba is investigating dial failures likely related to downstream telephony provider. Some calls are failing to connect.
Posted Jul 21, 2025 - 11:27 PDT
This incident affected: Voice Carrier (Voice Carrier).