Number Inventory Depleted
Incident Report for Ringba
Resolved
The issue affecting users when buying numbers has been resolved. No calls were negatively affected and all services have returned to normal operation.
Posted May 11, 2020 - 15:58 PDT
Investigating
We are experiencing issues due to inventory that has been depleted. Our team is working with our carrier partners to resolve the issue.
Posted May 11, 2020 - 09:34 PDT
This incident affected: Web Portal.