Potential carrier issue
Incident Report for Ringba
Resolved
This incident has been resolved.
Posted 8 days ago. Jul 08, 2019 - 11:01 PDT
Investigating
We are currently investigating this issue.
Posted 8 days ago. Jul 08, 2019 - 10:53 PDT
This incident affected: Voice Carrier (Plivo Voice).