Major Plivo Outage
Incident Report for Ringba
Resolved
Plivo is routing calls.
Posted about 1 year ago. Oct 15, 2018 - 18:40 PDT
Identified
Plivo is experiencing a Major outage.
Posted about 1 year ago. Oct 15, 2018 - 17:46 PDT
This incident affected: Voice Carrier (Plivo Voice).