Ring Tree process expired error for some calls

Incident Report for Ringba

Resolved

There was a very large, very fast spike in call activity. Auto-scale worked as expected, and we are reviewing for opportunities to improve scaling speed.
Posted Apr 25, 2025 - 14:07 PDT

Monitoring

Beginning at ~9:10 am ET, we saw an unusually large traffic burst, and some Ring Tree Targets started timing out. Services auto-scaled to compensate, and by ~9:20 am ET, ping timeouts were at a normal rate again. We are investigating the root cause of the timeouts.
Posted Apr 25, 2025 - 07:25 PDT