RTB Search Bids feature delay

Incident Report for Ringba

Resolved

The RTB Bid Search delays have been resolved, and the feature is now operational.
Posted Jun 25, 2025 - 19:45 PDT

Identified

We’re currently experiencing delays with the RTB Bid search feature. Please note that this does not impact bidding functionality—only search results are affected. The data will be available shortly.
Posted Jun 25, 2025 - 12:00 PDT