Delayed reporting
Incident Report for Ringba
Resolved
The earlier issue has been resolved. No calls were negatively affected and reporting has caught back up to current time.
Posted Mar 27, 2020 - 15:42 PDT
Identified
We're currently experiencing a delay in reporting. All of the call logs and details are fine and will be available shortly.
Posted Mar 27, 2020 - 12:39 PDT
This incident affected: Web Portal.