Ringba reporting delay
Incident Report for Ringba
Resolved
Reporting delays have been resolved. No data loss and no calls were affected. We are monitoring.
Posted Feb 06, 2024 - 09:05 PST
Identified
Ringba reporting is presently experiencing a delay. Calls are not affected. We will update you with more information shortly.
Posted Feb 06, 2024 - 08:33 PST