Unusually high caller hangup

Incident Report for Ringba

Resolved

Confirmed all recordings caught up. Incident resolved.
Posted Aug 07, 2026 - 12:00 PDT

Update

Recordings remain delayed but are being processed. We will update when they are caught up.
Posted Aug 07, 2026 - 08:24 PDT

Monitoring

Call connection rates returned to normal as of 14:58 UTC. We are continuing to monitor and confirm normal call flows.
Posted Aug 07, 2026 - 08:16 PDT

Investigating

Ringba is aware of several reports of excessive caller hangup, dead air calls, and missing recordings. We are investigating with the carrier.
Posted Aug 07, 2026 - 07:40 PDT
This incident affected: Voice Carrier (Voice Carrier).