Service Impact

Incident Report for Ringba

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 16:52 PDT

Monitoring

Ringba experienced temporary connection errors resulting in some calls and pings to fail. Our team has addressed the issue and is monitoring performance.
Posted Jun 05, 2026 - 14:28 PDT
This incident affected: Ringba API (api.ringba.com), Web Portal (app.ringba.com), Real Time Bidding (rtb.ringba.com) and Voice Carrier (Call XML Service (twiml.ringba.com)).