Calls impacted by downstream issue

Incident Report for Ringba

Resolved

Retroactive update:
Calls impacted by a downstream issue between 14:05-14:20 UTC.
Issue was resolved and is being monitored. Further details available at https://status.telnyx.com/
Posted Aug 11, 2025 - 07:30 PDT