Reporting delayed

Incident Report for Ringba

Resolved

Calls have been reprocessed and are available in reporting. A few calls are missing and will be reprocessed overnight.
Posted May 21, 2026 - 17:16 PDT

Monitoring

Call reprocessing is underway, calls are starting to be available in reporting. We expect to be caught up within 30 minutes. Some calls will still be missing from reporting, we will be reprocessing those separately.
Posted May 21, 2026 - 16:59 PDT

Identified

Call reporting is delayed due to an issue related to a software release tonight. We have rolled back and are taking corrective action and will advice when reporting data is processing normally.

Calls are processing normally, but there is a reporting backlog currently.
Posted May 21, 2026 - 16:24 PDT
This incident affected: Web Portal (app.ringba.com).